Project

General

Profile

Demande #3870

mise a jour de sécurité sur lamp

Added by Loïc Dachary 5 days ago. Updated 5 days ago.

Status:
Résolu
Priority:
Urgente
Assignee:
Category:
-
Target version:
Start date:
09/12/2019
Due date:
% Done:

0%

Difficulté:
2 Facile

Description

Les dépots jessie sont absents de sources.list et les mises à jour de sécurité de php5 manquent

ii libapache2-mod-php5 5.6.33+dfsg-0+deb8u1 amd64 server-side, HTML-embedded scripting language (Apache 2 module)
ii php5 5.6.33+dfsg-0+deb8u1 all server-side, HTML-embedded scripting language (metapackage)
ii php5-cli 5.6.33+dfsg-0+deb8u1 amd64 command-line interpreter for the php5 scripting language
ii php5-common 5.6.33+dfsg-0+deb8u1 amd64 Common files for packages built from the php5 source
ii php5-curl 5.6.33+dfsg-0+deb8u1 amd64 CURL module for php5
ii php5-gd 5.6.33+dfsg-0+deb8u1 amd64 GD module for php5
ii php5-imap 5.6.33+dfsg-0+deb8u1 amd64 IMAP module for php5
ii php5-intl 5.6.33+dfsg-0+deb8u1 amd64 internationalisation module for php5
ii php5-json 1.3.6-1 amd64 JSON module for php5
ii php5-mcrypt 5.6.33+dfsg-0+deb8u1 amd64 MCrypt module for php5
ii php5-mysql 5.6.33+dfsg-0+deb8u1 amd64 MySQL module for php5
rc php5-mysqlnd 5.6.20+dfsg-0+deb8u1 amd64 MySQL module for php5 (Native Driver)
rc php5-pspell 5.6.33+dfsg-0+deb8u1 amd64 pspell module for php5

History

#1 Updated by Loïc Dachary 5 days ago

cat > /etc/apt/sources.list.d/jessie.list <<EOF
deb http://security.debian.org/ jessie/updates main                                                                                                                        
deb http://deb.debian.org/debian jessie-updates main
deb http://deb.debian.org/debian jessie main
EOF
apt-get update
apt-get install -y php5 php5-cli php5-common php5-curl php5-gd php5-imap php5-intl php5-json php5-mcrypt php5-mysql

#2 Updated by Loïc Dachary 5 days ago

apt-get install php5 php5-cli php5-common php5-curl php5-gd php5-imap php5-intl php5-json php5-mcrypt php5-mysql
Reading package lists... Done
Building dependency tree       
Reading state information... Done
php5-json is already the newest version (1.3.6-1).
php5-json set to manually installed.
The following package was automatically installed and is no longer required:
  linux-image-4.9.0-8-amd64
Use 'apt autoremove' to remove it.
Suggested packages:
  php5-user-cache
Recommended packages:
  php5-readline
The following packages will be upgraded:
  libapache2-mod-php5 php5 php5-cli php5-common php5-curl php5-gd php5-imap php5-intl php5-mcrypt php5-mysql
10 upgraded, 0 newly installed, 0 to remove and 26 not upgraded.
Need to get 5,457 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://security.debian.org jessie/updates/main amd64 php5-mysql amd64 5.6.40+dfsg-0+deb8u5 [65.8 kB]
Get:2 http://security.debian.org jessie/updates/main amd64 php5-mcrypt amd64 5.6.40+dfsg-0+deb8u5 [15.6 kB]
Get:3 http://security.debian.org jessie/updates/main amd64 php5-intl amd64 5.6.40+dfsg-0+deb8u5 [112 kB]
Get:4 http://security.debian.org jessie/updates/main amd64 php5-imap amd64 5.6.40+dfsg-0+deb8u5 [31.7 kB]
Get:5 http://security.debian.org jessie/updates/main amd64 php5-gd amd64 5.6.40+dfsg-0+deb8u5 [29.2 kB]
Get:6 http://security.debian.org jessie/updates/main amd64 php5-curl amd64 5.6.40+dfsg-0+deb8u5 [28.0 kB]
Get:7 http://security.debian.org jessie/updates/main amd64 php5-cli amd64 5.6.40+dfsg-0+deb8u5 [2,199 kB]
Get:8 http://security.debian.org jessie/updates/main amd64 libapache2-mod-php5 amd64 5.6.40+dfsg-0+deb8u5 [2,229 kB]
Get:9 http://security.debian.org jessie/updates/main amd64 php5-common amd64 5.6.40+dfsg-0+deb8u5 [745 kB]
Get:10 http://security.debian.org jessie/updates/main amd64 php5 all 5.6.40+dfsg-0+deb8u5 [1,312 B]
Fetched 5,457 kB in 0s (11.0 MB/s)
(Reading database ... 90613 files and directories currently installed.)
Preparing to unpack .../0-php5-mysql_5.6.40+dfsg-0+deb8u5_amd64.deb ...
Unpacking php5-mysql (5.6.40+dfsg-0+deb8u5) over (5.6.33+dfsg-0+deb8u1) ...
Preparing to unpack .../1-php5-mcrypt_5.6.40+dfsg-0+deb8u5_amd64.deb ...
Unpacking php5-mcrypt (5.6.40+dfsg-0+deb8u5) over (5.6.33+dfsg-0+deb8u1) ...
Preparing to unpack .../2-php5-intl_5.6.40+dfsg-0+deb8u5_amd64.deb ...
Unpacking php5-intl (5.6.40+dfsg-0+deb8u5) over (5.6.33+dfsg-0+deb8u1) ...
Preparing to unpack .../3-php5-imap_5.6.40+dfsg-0+deb8u5_amd64.deb ...
Unpacking php5-imap (5.6.40+dfsg-0+deb8u5) over (5.6.33+dfsg-0+deb8u1) ...
Preparing to unpack .../4-php5-gd_5.6.40+dfsg-0+deb8u5_amd64.deb ...
Unpacking php5-gd (5.6.40+dfsg-0+deb8u5) over (5.6.33+dfsg-0+deb8u1) ...
Preparing to unpack .../5-php5-curl_5.6.40+dfsg-0+deb8u5_amd64.deb ...
Unpacking php5-curl (5.6.40+dfsg-0+deb8u5) over (5.6.33+dfsg-0+deb8u1) ...
Preparing to unpack .../6-php5-cli_5.6.40+dfsg-0+deb8u5_amd64.deb ...
Unpacking php5-cli (5.6.40+dfsg-0+deb8u5) over (5.6.33+dfsg-0+deb8u1) ...
Preparing to unpack .../7-libapache2-mod-php5_5.6.40+dfsg-0+deb8u5_amd64.deb ...
Unpacking libapache2-mod-php5 (5.6.40+dfsg-0+deb8u5) over (5.6.33+dfsg-0+deb8u1) ...
Preparing to unpack .../8-php5-common_5.6.40+dfsg-0+deb8u5_amd64.deb ...
Unpacking php5-common (5.6.40+dfsg-0+deb8u5) over (5.6.33+dfsg-0+deb8u1) ...
Preparing to unpack .../9-php5_5.6.40+dfsg-0+deb8u5_all.deb ...
Unpacking php5 (5.6.40+dfsg-0+deb8u5) over (5.6.33+dfsg-0+deb8u1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up php5-common (5.6.40+dfsg-0+deb8u5) ...
Setting up php5-mysql (5.6.40+dfsg-0+deb8u5) ...
Setting up php5-curl (5.6.40+dfsg-0+deb8u5) ...
Setting up php5-intl (5.6.40+dfsg-0+deb8u5) ...
Setting up php5-mcrypt (5.6.40+dfsg-0+deb8u5) ...
Setting up php5-imap (5.6.40+dfsg-0+deb8u5) ...
Setting up php5-cli (5.6.40+dfsg-0+deb8u5) ...
Setting up php5-gd (5.6.40+dfsg-0+deb8u5) ...
Setting up libapache2-mod-php5 (5.6.40+dfsg-0+deb8u5) ...
apache2_invoke php5: already enabled
Setting up php5 (5.6.40+dfsg-0+deb8u5) ...
Scanning processes...                                                                                                                                                      
Scanning linux images...                                                                                                                                                   
Running kernel seems to be up-to-date.
No services need to be restarted.
No containers need to be restarted.
No user sessions are running outdated binaries.

#3 Updated by Loïc Dachary 5 days ago

  • Status changed from En cours de traitement to Résolu

Also available in: Atom PDF