Project

General

Profile

Demande #5086

Mise à jour de ejabberd vers la version 20.12

Added by Adrien Bourmault 11 months ago. Updated 9 months ago.

Status:
Attente d'information
Priority:
Faible
Target version:
Start date:
01/03/2021
Due date:
% Done:

0%

Estimated time:
Difficulté:
2 Facile

Description

Nouvelle mise à jour proposée par apt.

Cette nouvelle version inclut de nombreux changements : https://www.process-one.net/blog/ejabberd-20-12/

History

#1

Updated by Adrien Bourmault 11 months ago

  • Status changed from En cours de traitement to Attente d'information
  • Priority changed from Normale to Faible

Pas assez de recul sur cette nouvelle version qui est sortie en upstream il y a moins de deux semaines.
Beaucoup de problèmes de compatibilité liés aux changements effectués par cette version (voir https://github.com/processone/ejabberd/issues/3459 où Conversations est incapable de se connecter avec les paramètres par défaut du serveur).

Je préconise d'attendre un peu, le temps que les bugs soit rapportés et qu'on ait une meilleure visibilité

#2

Updated by pitchum . 11 months ago

Pour éviter une mise à jour accidentelle j'ai baissé la priorité du dépôt backports (par défaut à 100) en modifiant le fichier /etc/apt/preferences.d/custom.pref comme suit :

@@ -2,6 +2,10 @@ Package: *
 Pin: release o=Debian,n=buster
 Pin-Priority: 850

+Package: *
+Pin: release o=Debian,n=buster-backports
+Pin-Priority: 90
+
 Package: *
 Pin: release o=Debian,n=bullseye
 Pin-Priority: 80

#3

Updated by pitchum . 9 months ago

Pour info le ticket github ejabberd #3459 a été fermé et le problème est résolu dans ejabberd-21.01 déjà dispo chez Debian bullseye et buster-backports.
Côté Conversations la prise en charge de SCRAM-256 a été corrigée à partir de la version 2.9.3.

#4

Updated by Adrien Bourmault 9 months ago

Probabilité non négligeable que des utilisateurs utilisent une version antérieure à 2.9.3 (car corrigé en décembre). Attendre encore est préférable

Also available in: Atom PDF