Project

General

Profile

Demande #5157

Mise à jour de bénévalibre

Added by François Poulain 10 months ago. Updated 10 months ago.

Status:
Fermé
Priority:
Normale
Start date:
01/28/2021
Due date:
% Done:

0%

Estimated time:

Description

=(^-^)=root@lamp:~# su - www-data -s /bin/bash

www-data@lamp:~$ cd benevalibre.chapril.org/benevalibre/

www-data@lamp:~/benevalibre.chapril.org/benevalibre$ git status
Rafraîchir l'index: 100% (324/324), fait.
Sur la branche master
Votre branche est en retard sur 'origin/master' de 35 commits, et peut être mise à jour en avance rapide.
  (utilisez "git pull" pour mettre à jour votre branche locale)

rien à valider, la copie de travail est propre

www-data@lamp:~/benevalibre.chapril.org/benevalibre$ git pull
Mise à jour 929b4b4..484f168
Fast-forward
 CHANGELOG.md                                            |  21 +++++++++++
 Makefile                                                |  10 ++++-
 README.md                                               |  56 +++++++++++++++++++---------
 assets/js/stats.js                                      |  18 +++++----
 assets/scss/layout/_stats.scss                          |  49 +++++++++++++++++++++---
 benevalibre/__init__.py                                 |   2 +-
 benevalibre/association/models.py                       |   3 ++
 benevalibre/association/tests/test_models.py            |  27 ++++++++++++++
 benevalibre/association/tests/test_views.py             | 302 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++---
 benevalibre/association/urls.py                         |   1 +
 benevalibre/association/views.py                        | 165 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++-
 benevalibre/base/management/commands/dump_stats.py      |  40 ++++++++++++++++++++
 benevalibre/base/tests/test_views.py                    |  25 ++++++++++---
 benevalibre/base/utils.py                               | 114 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 benevalibre/base/views.py                               | 100 ++++++++++++++-----------------------------------
 benevalibre/static/css/app.css                          | Bin 206841 -> 208397 bytes
 benevalibre/static/css/app.css.map                      | Bin 518810 -> 521184 bytes
 benevalibre/static/css/app.min.css                      | Bin 164191 -> 165525 bytes
 benevalibre/static/js/stats.js                          | Bin 1247522 -> 1247681 bytes
 benevalibre/static/js/stats.js.map                      | Bin 2270886 -> 2271285 bytes
 benevalibre/static/js/stats.min.js                      | Bin 542265 -> 542388 bytes
 benevalibre/static/vendor/chart.js/Chart.bundle.js      | Bin 593984 -> 0 bytes
 benevalibre/static/vendor/chart.js/Chart.bundle.min.js  | Bin 226496 -> 0 bytes
 benevalibre/static/vendor/chart.js/Chart.js             | Bin 443106 -> 0 bytes
 benevalibre/static/vendor/chart.js/Chart.min.js         | Bin 173077 -> 0 bytes
 benevalibre/templates/association/association_list.html |   4 +-
 benevalibre/templates/association/stats.html            | 195 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 benevalibre/templates/base/stats.html                   |  26 +++++++------
 28 files changed, 1024 insertions(+), 134 deletions(-)
 create mode 100644 benevalibre/base/management/commands/dump_stats.py
 create mode 100644 benevalibre/base/utils.py
 delete mode 100755 benevalibre/static/vendor/chart.js/Chart.bundle.js
 delete mode 100755 benevalibre/static/vendor/chart.js/Chart.bundle.min.js
 delete mode 100755 benevalibre/static/vendor/chart.js/Chart.js
 delete mode 100755 benevalibre/static/vendor/chart.js/Chart.min.js
 create mode 100644 benevalibre/templates/association/stats.html

www-data@lamp:~/benevalibre.chapril.org/benevalibre$ make update
venv/bin/pip install --upgrade --requirement requirements/production.txt
Requirement already up-to-date: tablib<0.12,>=0.11 in ./venv/lib/python3.7/site-packages (from -r requirements/base.txt (line 4)) (0.11.5)
Collecting requests
  Downloading requests-2.25.1-py2.py3-none-any.whl (61 kB)
     |████████████████████████████████| 61 kB 681 kB/s 
Collecting packaging
  Downloading packaging-20.8-py2.py3-none-any.whl (39 kB)
Requirement already up-to-date: django<2.3,>=2.2 in ./venv/lib/python3.7/site-packages (from -r requirements/base.txt (line 12)) (2.2.17)
Requirement already up-to-date: django-environ==0.4.5 in ./venv/lib/python3.7/site-packages (from -r requirements/base.txt (line 13)) (0.4.5)
Requirement already up-to-date: django-registration-redux<2.7,>=2.6 in ./venv/lib/python3.7/site-packages (from -r requirements/base.txt (line 14)) (2.6)
Requirement already up-to-date: django-dynamic-filenames<1.2,>=1.1 in ./venv/lib/python3.7/site-packages (from -r requirements/base.txt (line 16)) (1.1.4)
Collecting django-reversion<3.1,>=3.0
  Downloading django_reversion-3.0.9-py3-none-any.whl (85 kB)
     |████████████████████████████████| 85 kB 438 kB/s 
Requirement already up-to-date: django-stdimage<4.2,>=4.1 in ./venv/lib/python3.7/site-packages (from -r requirements/base.txt (line 18)) (4.1.0)
Collecting django-tables2
  Downloading django_tables2-2.3.4-py2.py3-none-any.whl (91 kB)
     |████████████████████████████████| 91 kB 943 kB/s 
Requirement already up-to-date: django-tapeforms<0.3,>=0.2 in ./venv/lib/python3.7/site-packages (from -r requirements/base.txt (line 21)) (0.2.1)
Requirement already up-to-date: django-cruditor<1.4,>=1.3 in ./venv/lib/python3.7/site-packages (from -r requirements/base.txt (line 22)) (1.3.2)
Requirement already up-to-date: django-filter<2.3,>=2.2 in ./venv/lib/python3.7/site-packages (from -r requirements/base.txt (line 23)) (2.2.0)
Collecting sphinx
  Downloading Sphinx-3.4.3-py3-none-any.whl (2.9 MB)
     |████████████████████████████████| 2.9 MB 94 kB/s 
Collecting sphinx-rtd-theme
  Downloading sphinx_rtd_theme-0.5.1-py2.py3-none-any.whl (2.8 MB)
     |████████████████████████████████| 2.8 MB 21.5 MB/s 
Requirement already up-to-date: django-docs in ./venv/lib/python3.7/site-packages (from -r requirements/base.txt (line 29)) (0.3.1)
Requirement already satisfied, skipping upgrade: pyyaml in ./venv/lib/python3.7/site-packages (from tablib<0.12,>=0.11->-r requirements/base.txt (line 4)) (5.3.1)
Requirement already satisfied, skipping upgrade: xlwt in ./venv/lib/python3.7/site-packages (from tablib<0.12,>=0.11->-r requirements/base.txt (line 4)) (1.3.0)
Requirement already satisfied, skipping upgrade: unicodecsv in ./venv/lib/python3.7/site-packages (from tablib<0.12,>=0.11->-r requirements/base.txt (line 4)) (0.14.1)
Requirement already satisfied, skipping upgrade: openpyxl in ./venv/lib/python3.7/site-packages (from tablib<0.12,>=0.11->-r requirements/base.txt (line 4)) (3.0.5)
Requirement already satisfied, skipping upgrade: odfpy in ./venv/lib/python3.7/site-packages (from tablib<0.12,>=0.11->-r requirements/base.txt (line 4)) (1.4.1)
Requirement already satisfied, skipping upgrade: xlrd in ./venv/lib/python3.7/site-packages (from tablib<0.12,>=0.11->-r requirements/base.txt (line 4)) (1.2.0)
Requirement already satisfied, skipping upgrade: idna<3,>=2.5 in /usr/lib/python3/dist-packages (from requests->-r requirements/base.txt (line 6)) (2.6)
Requirement already satisfied, skipping upgrade: certifi>=2017.4.17 in /usr/lib/python3/dist-packages (from requests->-r requirements/base.txt (line 6)) (2018.8.24)
Requirement already satisfied, skipping upgrade: urllib3<1.27,>=1.21.1 in /usr/lib/python3/dist-packages (from requests->-r requirements/base.txt (line 6)) (1.24.1)
Requirement already satisfied, skipping upgrade: chardet<5,>=3.0.2 in /usr/lib/python3/dist-packages (from requests->-r requirements/base.txt (line 6)) (3.0.4)
Requirement already satisfied, skipping upgrade: pyparsing>=2.0.2 in ./venv/lib/python3.7/site-packages (from packaging->-r requirements/base.txt (line 8)) (2.4.7)
Requirement already satisfied, skipping upgrade: sqlparse>=0.2.2 in ./venv/lib/python3.7/site-packages (from django<2.3,>=2.2->-r requirements/base.txt (line 12)) (0.4.1)
Requirement already satisfied, skipping upgrade: pytz in ./venv/lib/python3.7/site-packages (from django<2.3,>=2.2->-r requirements/base.txt (line 12)) (2020.1)
Requirement already satisfied, skipping upgrade: progressbar2>=3.0.0 in ./venv/lib/python3.7/site-packages (from django-stdimage<4.2,>=4.1->-r requirements/base.txt (line 18)) (3.53.1)
Requirement already satisfied, skipping upgrade: pillow>=2.5 in ./venv/lib/python3.7/site-packages (from django-stdimage<4.2,>=4.1->-r requirements/base.txt (line 18)) (8.0.1)
Requirement already satisfied, skipping upgrade: babel>=1.3 in ./venv/lib/python3.7/site-packages (from sphinx->-r requirements/base.txt (line 27)) (2.8.0)
Requirement already satisfied, skipping upgrade: Pygments>=2.0 in ./venv/lib/python3.7/site-packages (from sphinx->-r requirements/base.txt (line 27)) (2.7.2)
Requirement already satisfied, skipping upgrade: docutils>=0.12 in ./venv/lib/python3.7/site-packages (from sphinx->-r requirements/base.txt (line 27)) (0.16)
Requirement already satisfied, skipping upgrade: imagesize in ./venv/lib/python3.7/site-packages (from sphinx->-r requirements/base.txt (line 27)) (1.2.0)
Requirement already satisfied, skipping upgrade: snowballstemmer>=1.1 in ./venv/lib/python3.7/site-packages (from sphinx->-r requirements/base.txt (line 27)) (2.0.0)
Requirement already satisfied, skipping upgrade: setuptools in ./venv/lib/python3.7/site-packages (from sphinx->-r requirements/base.txt (line 27)) (50.3.2)
Requirement already satisfied, skipping upgrade: Jinja2>=2.3 in ./venv/lib/python3.7/site-packages (from sphinx->-r requirements/base.txt (line 27)) (2.11.2)
Requirement already satisfied, skipping upgrade: sphinxcontrib-qthelp in ./venv/lib/python3.7/site-packages (from sphinx->-r requirements/base.txt (line 27)) (1.0.3)
Requirement already satisfied, skipping upgrade: alabaster<0.8,>=0.7 in ./venv/lib/python3.7/site-packages (from sphinx->-r requirements/base.txt (line 27)) (0.7.12)
Requirement already satisfied, skipping upgrade: sphinxcontrib-jsmath in ./venv/lib/python3.7/site-packages (from sphinx->-r requirements/base.txt (line 27)) (1.0.1)
Requirement already satisfied, skipping upgrade: sphinxcontrib-serializinghtml in ./venv/lib/python3.7/site-packages (from sphinx->-r requirements/base.txt (line 27)) (1.1.4)
Requirement already satisfied, skipping upgrade: sphinxcontrib-devhelp in ./venv/lib/python3.7/site-packages (from sphinx->-r requirements/base.txt (line 27)) (1.0.2)
Requirement already satisfied, skipping upgrade: sphinxcontrib-htmlhelp in ./venv/lib/python3.7/site-packages (from sphinx->-r requirements/base.txt (line 27)) (1.0.3)
Requirement already satisfied, skipping upgrade: sphinxcontrib-applehelp in ./venv/lib/python3.7/site-packages (from sphinx->-r requirements/base.txt (line 27)) (1.0.2)
Requirement already satisfied, skipping upgrade: jdcal in ./venv/lib/python3.7/site-packages (from openpyxl->tablib<0.12,>=0.11->-r requirements/base.txt (line 4)) (1.4.1)
Requirement already satisfied, skipping upgrade: et-xmlfile in ./venv/lib/python3.7/site-packages (from openpyxl->tablib<0.12,>=0.11->-r requirements/base.txt (line 4)) (1.0.1)
Requirement already satisfied, skipping upgrade: defusedxml in ./venv/lib/python3.7/site-packages (from odfpy->tablib<0.12,>=0.11->-r requirements/base.txt (line 4)) (0.6.0)
Requirement already satisfied, skipping upgrade: python-utils>=2.3.0 in ./venv/lib/python3.7/site-packages (from progressbar2>=3.0.0->django-stdimage<4.2,>=4.1->-r requirements/base.txt (line 18)) (2.4.0)
Requirement already satisfied, skipping upgrade: six in /usr/lib/python3/dist-packages (from progressbar2>=3.0.0->django-stdimage<4.2,>=4.1->-r requirements/base.txt (line 18)) (1.12.0)
Requirement already satisfied, skipping upgrade: MarkupSafe>=0.23 in ./venv/lib/python3.7/site-packages (from Jinja2>=2.3->sphinx->-r requirements/base.txt (line 27)) (1.1.1)
Installing collected packages: requests, packaging, django-reversion, django-tables2, sphinx, sphinx-rtd-theme
  Attempting uninstall: requests
    Found existing installation: requests 2.25.0
    Uninstalling requests-2.25.0:
      Successfully uninstalled requests-2.25.0
  Attempting uninstall: packaging
    Found existing installation: packaging 20.4
    Uninstalling packaging-20.4:
      Successfully uninstalled packaging-20.4
  Attempting uninstall: django-reversion
    Found existing installation: django-reversion 3.0.8
    Uninstalling django-reversion-3.0.8:
      Successfully uninstalled django-reversion-3.0.8
  Attempting uninstall: django-tables2
    Found existing installation: django-tables2 2.3.3
    Uninstalling django-tables2-2.3.3:
      Successfully uninstalled django-tables2-2.3.3
  Attempting uninstall: sphinx
    Found existing installation: Sphinx 3.3.1
    Uninstalling Sphinx-3.3.1:
      Successfully uninstalled Sphinx-3.3.1
  Attempting uninstall: sphinx-rtd-theme
    Found existing installation: sphinx-rtd-theme 0.5.0
    Uninstalling sphinx-rtd-theme-0.5.0:
      Successfully uninstalled sphinx-rtd-theme-0.5.0
Successfully installed django-reversion-3.0.9 django-tables2-2.3.4 packaging-20.8 requests-2.25.1 sphinx-3.4.3 sphinx-rtd-theme-0.5.1
WARNING: You are using pip version 20.2.4; however, version 21.0 is available.
You should consider upgrading via the '/var/www/benevalibre.chapril.org/benevalibre/venv/bin/python3 -m pip install --upgrade pip' command.
venv/bin/python3 manage.py migrate
Operations to perform:
  Apply all migrations: accounts, association, auth, benevalo, contenttypes, instance, registration, reversion, sessions
Running migrations:
  No migrations to apply.
Collecte des fichiers statiques...
venv/bin/python3 manage.py collectstatic --no-input --verbosity 0
make -C docs/ html SPHINXBUILD=../venv/bin/sphinx-build
make[1] : on entre dans le répertoire « /var/www/benevalibre.chapril.org/benevalibre/docs »
../venv/bin/sphinx-build -b html "source" "build/html" -d build/doctrees
Sphinx v3.4.3 en cours d'exécution
Chargement des traductions [fr]... fait
/var/www/benevalibre.chapril.org/benevalibre/docs/source/conf.py:118: RemovedInSphinx40Warning: The app.add_stylesheet() is deprecated. Please use app.add_css_file() instead.
  app.add_stylesheet('css/custom.css')
chargement de l'environnement pickled... fait
construction en cours [mo]:cibles pour les fichiers po 0 qui sont périmées
construction [html]:cibles pour les fichiers sources 13 qui sont périmées
mise-à-jour de l'environnement :[la configuration a changé ('version')] 13 ajouté, 0 modifié, 0 supprimé
lecture des sources... [100%] utilisation/moderer_association                                                                                                                                                      
recherche des fichiers périmés... aucun résultat
environnement de sérialisation... fait
vérification de la cohérence... fait
document en préparation... fait
écriture... [100%] utilisation/moderer_association                                                                                                                                                                 
generating indices... genindex fait
writing additional pages... search fait
copying static files... fait
copying extra files... fait
dumping search index in French (code: fr)... fait
dumping object inventory... fait
la compilation a réussi.

Les pages HTML sont dans build/html .
make[1] : on quitte le répertoire « /var/www/benevalibre.chapril.org/benevalibre/docs »
venv/bin/python3 manage.py rendervariations --ignore-missing --replace \
  'accounts.User.avatar' 'association.Association.logo'
| | CPUs: 1 | Time:  0:00:00 | 100% |############################################################################################################################################################################|
| | CPUs: 1 | Time:  0:00:00 | 100% |############################################################################################################################################################################|
touch benevalibre/wsgi.py
www-data@lamp:~/benevalibre.chapril.org/benevalibre$ déconnexion

=(^-^)=root@lamp:~# systemctl reload apache2.service 

=(^-^)=root@lamp:~# déconnexion

Related issues

Copied to benevalibre.chapril.org - Demande #5202: Mise à jour de bénévalibre en 1.3.0Nouveau01/28/2021

Actions

History

#1

Updated by François Poulain 10 months ago

  • Status changed from Nouveau to Résolu
  • Assignee set to François Poulain
#2

Updated by Christian P. Momon 10 months ago

  • Status changed from Résolu to Fermé
#3

Updated by Christian P. Momon 10 months ago

  • Target version changed from Backlog to Sprint 2021 janvier
#4

Updated by Christian P. Momon 10 months ago

  • Copied to Demande #5202: Mise à jour de bénévalibre en 1.3.0 added

Also available in: Atom PDF