Project

General

Profile

Demande #5571

Demande #5562: Migrer l'infra en Bullseye

Migrer sympa sur Bullseye

Added by Quentin Gibeaux over 1 year ago. Updated 9 months ago.

Status:
Résolu
Priority:
Faible
Category:
-
Target version:
Start date:
09/02/2021
Due date:
% Done:

100%

Estimated time:
Spent time:
Difficulté:
2 Facile

Description

voir titre


Related issues

Related to Admins - Demande #3945: Migrer vers Debian Buster la vm sympaFermé10/21/2019

Actions
Related to Admins - Anomalie #4667: Problème avec les liens html dans la description des listes sur WWSympaFermé08/18/2020

Actions
Related to Admins - Anomalie #4668: Mauvais message affiché par WWSympa lors d'une inscription à une listeFermé08/18/2020

Actions
Copied from Admins - Demande #5570: Migrer mail sur BullseyeRésolu09/02/2021

Actions
Copied to Admins - Demande #5572: Migrer adl sur BullseyeRésolu09/02/2021

Actions

History

#1

Updated by Quentin Gibeaux over 1 year ago

#2

Updated by Quentin Gibeaux over 1 year ago

#3

Updated by Christian P. Momon over 1 year ago

  • Related to Demande #3945: Migrer vers Debian Buster la vm sympa added
#4

Updated by Pierre-Louis Bonicoli 9 months ago

  • Status changed from Nouveau to En cours de traitement
#5

Updated by Pierre-Louis Bonicoli 9 months ago

  • Assignee set to Pierre-Louis Bonicoli
  • Priority changed from Normale to Faible
#6

Updated by Pierre-Louis Bonicoli 9 months ago

  • virola: @virsh snapshot-create-as sympa avant_upgrade_bullseye
  • ✅ purge des paquets obsolètes/transitional: libnagios-plugin-perl libprocps3:amd64 libreadline6:amd64 libxtables10 heirloom-mailx lynx-cur openssh-blacklist2 gcc-4.9-base libmpfr4 liblvm2cmd2.02 liblognorm1 liblogging-stdlog0 libjson-c2 libgdbm3 libelfg0 libcryptsetup4 libboost-iostreams1.55.0 libasprintf0c2 libapt-pkg4.12 libapt-inst1.5
  • ✅ apt update && apt dist-upgrade -y
  • cd /srv/common; git checkout -b bullseye; git branch --set-upstream-to=origin/bullseye bullseye ; git pull
  • sed -e 's/buster/bullseye/g' -i /etc/apt/sources.list
  • sed -e 's/buster/bullseye/g' -i /etc/apt/sources.list.d/*
  • ✅ correction du dépôt security, ajout des deb-src, utilisation de deb.debian.org plutôt que ftp.fr.debian.org
  • apt update
  • apt install apt
  • DEBIAN_FRONTEND=noninteractive apt -o DPKG::Options::="--force-confold" dist-upgrade -y => failure due to incompatible changes in sympa configuration
  • ✅ update and commit sympa configuration
  • dpkg --configure sympa
  • dpkg -C
  • apt dist-upgrade -y
  • find /etc -type f -name '*dist*' => delete old files, take in account new ones
  • systemctl reboot
  • ✅ purge des paquets obsolètes/transitional: mariadb-server-10.3 mariadb-client-10.3 libcomerr2 libpython3.7-minimal linux-image-4.19.0-6-amd64 linux-image-4.19.0-8-amd64 linux-image-4.19.0-9-amd64 e2fslibs python3.7-minimal
  • systemctl reboot
  • ✅ le service https://listes.april.org/ est ok
#7

Updated by Pierre-Louis Bonicoli 9 months ago

  • Status changed from En cours de traitement to Résolu
  • % Done changed from 0 to 100
#8

Updated by Pierre-Louis Bonicoli 9 months ago

Le patchs correctifs mentionnés dans les ticket #4667 et #4668 ont été appliqués.

#9

Updated by Pierre-Louis Bonicoli 9 months ago

  • Related to Anomalie #4667: Problème avec les liens html dans la description des listes sur WWSympa added
#10

Updated by Pierre-Louis Bonicoli 9 months ago

  • Related to Anomalie #4668: Mauvais message affiché par WWSympa lors d'une inscription à une liste added

Also available in: Atom PDF